Updated Win64 shmupmametgm build

Thread in 'Discussion' started by Altimor, 28 Nov 2015.

  1. Altimor

    Altimor a.k.a. Ghett0

    Last edited: 28 Nov 2015
    Betelgeuse, Jii, gontrollez and 2 others like this.
  2. Thanks for the work, but running it even as admin gives a popup Entry Point not Found

    "The procedure entry point __gxx_personality_seh0 could not be located in the dynamic link library C:\Users...yadayadayada...\mametgm64.exe"

    Does this require a dll on the wiki I'm not seeing or was it not compiled correctly? I'll try and compile the source this weekend if it's not resolved by then. Super stoked to play a lagless TAP since I'm just trying to take down that torikan now.
     
  3. Altimor

    Altimor a.k.a. Ghett0

    It was missing a -static-libstdc++. The new version I uploaded should work for you.
     
  4. Muf

    Muf

    Works great! And of course, if you're using an old mame.ini, don't forget to set refreshspeed and syncrefresh to 0. You can tell your settings are correct if when pressing F11 the text in the top right shows "skip 0/10 100%".
     
  5. I'm still using WinXP32 for my mame cab. Do you have 32bit version compiled?
     
  6. a) Thanks for your great work!
    b) I would like to have a 32bit Version, too. Alternatively lets meet in IRC sometime and help me setup the project so I can compile it myself. ;)
     
  7. Altimor

    Altimor a.k.a. Ghett0

  8. Has anyone tried to compile this on Mac OS yet?

    I got a fatal error: 'SDL/SDL.h' file not found
     
  9. I've tried to a few times, but I can't figure out how to do it for the life of me. building mame's a bit of a nightmare on anything that isn't windows.

    With that specific error, you'll need to download and link the SDL library over here: https://www.libsdl.org/download-1.2.php
     
  10. http://tetrisconcept.net/threads/shmupmametgm-on-linux.2645/page-2#post-58232

    I went through hell trying to do that, and to my amazement I eventually succeeded. There were SO many errors, but I powered through.
    Unfortunately, the result was an unplayable laggy discolored mess and I immediately said fuck it.
     
  11. Anyone got a mirror for this? Link isn't working for me.
     

    Attached Files:

  12. Here you go!
     
    CPN, K and Rosti LFC like this.
  13. Ooh, didn't notice we had a fix for the framerate thing. Hooray!

    (except now getting death GM will be 2.75% harder =P)
     
  14. Sorry for the bump, but I just fixed the thing where when you try to launch TGM 1 it makes you waggle your joystick to acknowledge that their emulation was inaccurate. Rather than doing something useful like backporting whatever driver fixes were introduced, I just commented out the lines in /emu/ui.c so now it won't make you do any joystick waggling. Because this thing was such a pain in the ass to compile (requiring me to download a 7 year old version of Mingw and update one of the d3d header files with one from a 6 year old version of Mingw) I've gone to the trouble of packaging up a premade Windows build setup so you won't have to go through what I did if you want to change anything. You should just have to put the mingw folder in your path, go to the mamesrc directory, and run "make SUBTARGET=tgm NOWERROR=1"
    Just the binary: https://mega.nz/#!0goCHSJQ!CEIeGYnDq7eDy06AcCLFQ9rDPCat4M9o9vgDbVbCyTY
    Build setup and binary: https://mega.nz/#!J9Q3UChI!EglvRR_AdsXmDVK3VMBxu42o6YjkG2seaveQ4Jr8QDM
     
    Kitaru and Novomancy like this.

Share This Page