Thread in 'Discussion' started by Caithness, 18 Aug 2009.

  1. Muf


    Re: NullpoMino - now with netplay!

    Just log to /dev/null :awe:
  2. Re: NullpoMino - now with netplay!

    April 7th is when Wojtek's phantom self that won't disappear first happened. Might that be related?
  3. Re: NullpoMino - now with netplay!

    Failing to save line information is a bug. However, orange line outranking green line outranking no line is not a bug at all.

    Also, that green line game is ahead of the other two because it is a faster time, not because of anything to do with lines. It wouldn't be able to order the scores by lines if it doesn't save them!
  4. Re: NullpoMino - now with netplay!

    It's not a faster time: 3:35 vs 3:32 for #2.

    Maybe #1 is higher because green line is erroneously ranked higher than orange?
  5. m:)


    Re: NullpoMino - now with netplay!

    is there a way to access the netplay stuff in fullscreen mode?
  6. Re: NullpoMino - now with netplay!

    Nope. A couple more runs later, and the scores from top to bottom are something like green-orange-orange-green-orange-orange lines.
    A new score at level 999 ALWAYS goes in the #1 slot and pushes everything else down one slot, regardless of line or time.

    Also, an update on PoochyBot...
    It's still not as consistent as I'd like it to be (in particular, it has some issues with trying to cope with I piece droughts), but I suppose a passed exam is a passed exam.
  7. NullNoname

    NullNoname NullpoMino developer

    NullpoMino Version (2010/04/10)

    Thanks everyone for great feedbacks. The number of players have increased as well.
    So here is an update. It adds some options to the netplay.

    Version (2010/04/10)
    #This version is NOT compatible with 6.6 netplay server.
    +NetPlay: Now you can customize speed settings (gravity and various delays) and some game settings (T-Spin, B2B, and Combo).
    +NetPlay: Now you can see opponent's statistics in the lobby GUI.
    +NetPlay: Added auto start timer setting. When half or more players are ready, this timer will start ticking. Set the timer 0 to disable it.
    +NetPlay: AIs can be used (but there is a problem that F button doesn't work for single player game and practice game)
    *NetServer: Changed default log setting so the total log size will be limited to 50MB.
    -PHANTOM MANIA: Fixed a bug that green/orange lines not saved to the ranking.
    -PHANTOM MANIA: Fixed a bug that RO medal was shown as SK medal.

    * Download link *

    @Burbruee: 15GB!? I can't believe it! o_O I changed log setting file so it won't exceed 50MB.
    @m:): Until I add "2player no-chat random match" or something like that, you can't do that.
    @Poochy: Congratulations for passing GM exam! I fixed some of PHANTOM MANIA weirdness but I think there are still some bugs left.
  8. Re: NullpoMino - now with netplay!

    It did it again. Server filled with logs.
    When I resumed the screen session just now it shoots exception errors over and over again forever, it just keeps coming and that must be what fills up the logs.

    09:45:57,260 [Thread-0] ERROR NetServer: IOException throwed on doWrite Broken pipe
            at Method)
    09:45:57,277 [Thread-0] ERROR NetServer: IOException throwed on doWrite Broken pipe
            at Method)
    not sure if this helps resolve any bugs.

    I'll try the new version now.

    EDIT: mirror @
    EDIT: Server version up and running!
  9. Re: NullpoMino - now with netplay!

    I'm pretty sure what's causing the monster logs is when a player gets disconnected but a phantom copy of that player remains. The first time it was Wojtek, and the second time it was Turambar.

    I was there when it happened to Turambar. First he was complaining that NullpoMino was overloading his RAM, then that he was lagging, and finally he stopped responding altogether.

    Edit: Something else strange I've noticed: If I connect to the netplay server after a fresh install without changing the default rotation rule first, all my pieces are grey.
  10. Re: NullpoMino - now with netplay!

    In the default rule, the pieces are always gray, regardless of whether you are playing local or netplay. That's supposed to happen (at least, I would assume so).
  11. Re: NullpoMino - now with netplay!

    Oh, okay then. Is the default rule selectable as one of the menu options, or only by pressing the D button?
  12. Re: NullpoMino - now with netplay!

    No, you can only select the rule by using the D button. I'm pretty sure that rule is built into NullpoMino by forcing it to return all default values for all of the properties that would be read from a file.

    If you'll notice, when the default rule is set, it doesn't have a rule name in the "CURRENT:" area of the rule select screen.
  13. Re: NullpoMino - now with netplay!

    I love this program and think it's best ever.
    Of course it's nice that everyone here is happy and I'm not.
    When I use this program it's RAM usage slowly rises megabyte after megabyte. Eventually it reaches top and whole computer starts to lag and program crashes.
    I use blinks standardplus rule if that helps.
  14. Re: NullpoMino - now with netplay!

    Are you sure it's not a problem with your Java installation? Which version of Java and which OS are you using?
  15. Re: NullpoMino - now with netplay!

    Windows XP 32 SP 3
    Java latest version.
    All other apps work fine.
  16. Re: NullpoMino - now with netplay!

    Odd. I really don't know what to tell you. I'd suggest the possibility that Burbruee could look at the server logs to try to find out what the problem is, but I don't really know what gets logged.
  17. Re: NullpoMino - now with netplay!

    btw it only happens in netplay. Does not happen in single player.
  18. Re: NullpoMino - now with netplay!

    Something's wrong with the nullpo-server again.
    While the logs are now locked to 50 MB, instead I found about 10 or so logs filled with the following over and over.

    10-04-11 00:05:04,659 [Thread-0] ERROR
        2 Broken pipe
        3     at Method)
        4     at
        5     at
        6     at
        7     at
        8     at
        9     at
       10 10-04-11 00:05:04,660 [Thread-0] ERROR
       11 Broken pipe
       12     at Method)
       13     at
       14     at
       15     at
       16     at
       17     at
       18     at
       19 10-04-11 00:05:04,662 [Thread-0] ERROR
       20 Broken pipe
    You can see the timestamp there, and you can figure out how fast it could potentially eat diskspace. :p

    Not sure what's causing it, but looking at top, the java process takes up about 90 % cpu when it does that.
    Just restarted nullpo. Looks like I have to keep restarting it about once every day until there's a solution/bugfix.

    I could check out which JRE is running on the server tomorrow and update if needed.

    Edit: Woke up today and I had to restart it YET AGAIN.
    java -version
    java version "1.6.0"
    OpenJDK Runtime Environment (build 1.6.0-b09)
    OpenJDK Client VM (build 1.6.0-b09, mixed mode)
    On another note, I just installed ubuntu on my netbook, and Nullpomino refuses to start with the "OpenJDK" available from within ubuntu, using the one from is fine. Maybe the OpenJDK is to blame for all this?

    There, updated jre on the server to the one on

    java version "1.6.0_19"
    Java(TM) SE Runtime Environment (build 1.6.0_19-b04)
    Java HotSpot(TM) Client VM (build 16.2-b04, mixed mode, sharing)
    Let's hope there won't be any more problems. :(
    Last edited: 11 Apr 2010
  19. Re: NullpoMino - now with netplay!

    Version 7 still doesn't work. (Only Swing does, and that's nigh-unplayable)
    Might be my java install, but I've updated to the newest version and still nothing. No error messages this time either... oh well.
  20. Re: NullpoMino - now with netplay!

    Had to restart the server again. Exceptions.
    Bug in NullpoMino causes this?

    I also tried using my stick with Nullpomino, with limited success.
    First, plugging it in and starting the game the selector goes from top to bottom making it very hard to select an option. If I press down (on the keyboard) I can make the selector stop with a delay, so I have to do it a few times before I get it to stop where I want it to so I can select an option.

    Eventually going to config->general and selecting the stick. Then to config->joystick to configure it.
    When I finally start a game (with serious problems because of above said selector issues, probably took me 3 or 4 minutes to get it to stop on Grade Master 3) and it toggles all of the pre-game options such as exam, stime and starting level on it's own by going up and pressing left continuously. Once actually in-game every piece is dragging to the left. So the game is unplayable.

    ^ This was with the slick version. I had no such issues with SDL, however my netbook is far too slow to handle the SDL version. (slick gives 55-60 fps most of the time while SDL only gives me 20-30 fps) Calibrating the stick in windows control panel shows no signs of dragging up/left either, so I think the stick is OK and the problem is with the game.
    Last edited: 12 Apr 2010

Share This Page