does G-TET even exist?

Thread in 'Discussion' started by orz, 30 Oct 2019.

  1. orz


    seriously there is not a single screenshot anywhere and i've used all kinds of search operators and shit on google and cannot find anything aside from a few references to the game here and on japanese pages (which don't have any substantive information about the game on them)
  2. Zaphod77

    Zaphod77 Resident Misinformer

    I've been looking for it myself. i remember it and d-tet as two tetromino games that Mihara respected as not TGM clones (form what i remember reading). but i've only ever seen d-tet. never g-tet.
  3. orz


    i found a screenshot while i was searching around on yahoo jp
    there might be more out there, i only went a few pages in
  4. I think I stumbled on that person's blog before - here's a link for reference.

    Some time back I started compiling a list of lost games. GTET's on there, as well as a few other games (I suspect there are more Tetris-type games out there that have since been lost as well).

    colour_thief used to have a copy of GTET but it seems it's gone now. Contacting Japanese players may or may not help.

    EDIT: Tweet with the game's title screen
    Last edited: 2 Nov 2019
  5. Zaphod77

    Zaphod77 Resident Misinformer

    Last edited: 2 Nov 2019
  6. Zaphod77

    Zaphod77 Resident Misinformer

    okay got my laptop hard drive. i do have bomblin 0.97x. i'm tying to get my original download off of it. if not i have a new archive i can upload to my website.

    here's 0.97x

    this is NOT the original archive, which i no longer have. i have changed hold from c to space, and I have a few high scores. it is otherwise unmodified. I haven't figured out how to clear the ranking.

    on 0.95 controls are arrows, z ccw x cw c hold.

    on this one space is hold instead.

    keyconfig.exe doesn't seem to like my windows 10, and is looking for a missing DLL of some sort, though it does not say what one it is.if you want ti back to c for hold copy the key.ini from version 0.95

    manbows website still exists, but no longer appears to have the game, and he has nuked bomblin
    Last edited: 2 Nov 2019
    colour_thief and Arcorann like this.
  7. Thanks for finding Bomblin, really appreciate it. I've updated the list of lost games.
  8. Edo

    Edo a.k.a. FSY

    Here's a copy of GTET. If anyone manages to get it running properly, please post screenshots/videos.
    Arcorann, I only just noticed you sent me a pm asking about it back in August! Sorry you had to wait so long...

    Attached Files:

      File size:
      810.8 KB
    colour_thief, simonlc, Muf and 3 others like this.
  9. Tested the game in Windows 10 as well as a few VMs.

    The game works fine on Japanese Windows 98, while the font is wrong on English Windows 98. On Windows XP with ntleas the game hangs when trying to save scores (this was apparently a known bug related to using 16-bit code), but otherwise seems to play okay. The font is wrong in English Windows 10 as well, and also hangs when trying to save scores. Here's a small gallery:

    colour_thief and Muf like this.

  10. running in windows 10
    idk why but it makes a system sound every line clear
    also i couldnt get joystick to work and the controls felt unresponsive at times
    simonlc likes this.
  11. Nice thanks @Edo!

    Is it just me or are some backgrounds missing on there? Looks like the photos from the japanese user has some graphics.
  12. Edo

    Edo a.k.a. FSY

    If memory serves, GTET allows for custom backgrounds and sound effects. The windows system sound instead of the proper line clear effect is almost certainly the result of a missing .wav with the appropriate filename.
    Someone might like to have a look at the .exe with a hex editor - it could give a clue as to what filenames are expected.
  13. According to the official site's changelog the backgrounds should be named bg0.bmp to bg9.bmp. There are five audio files that aren't included in the package either.

    I didn't think to check if the sounds were working when I tested GTET the first time, now I check again I notice that they don't seem to work in Windows 98. I don't know if it's my setup so if possible I'd like someone else to check as well.
  14. no its not just you, ive tried gtet in my win2k vm + my actual win8.1 install and it still uses default windows sounds since a bunch of wav files are indeed missing:


    havent been able to add in proper .bmp backgrounds but every wav file ive tried works just fine
  15. I was referring to none of the sounds playing in my Windows 98 VM, not even the next piece sounds (which are fine elsewhere). I can't tell if it's a weird configuration in my VirtualBox setup though (considering trying it in PCem but would have to set it up from scratch again).

Share This Page